Feed Delay in Catalog - Over 3 hours

Incident Report for Smartly Status Page

Resolved

The issue has been resolved regarding the feed delays in Catalogs.
Posted Jun 30, 2026 - 21:01 UTC

Monitoring

We are currently experiencing degraded performance affecting Meta catalog feed processing. As a result, a subset of users may notice that catalog feed processing is taking significantly longer than usual, in some cases exceeding several hours.

This delay is caused by an ongoing processing issue on Meta's side that began last night and has continued into this morning. Since the processing is managed by Meta, we are unable to cancel or restart feeds that are currently being processed.

Performance is showing signs of recovery, and we expect processing times to return to normal soon.

A subset of catalog feed updates may be delayed. Existing ads will continue to deliver normally during this time. Feed processing will complete once Meta finishes processing the queued requests.

We apologise for any inconvenience this may cause and will provide another update as soon as the issue has been fully resolved.
Posted Jun 30, 2026 - 11:43 UTC
This incident affected: Advertising (Catalogs).